新盟教育内部课程分享-Vlan实验

[复制链接]
新盟教育 发表于 2017-6-27 21:42 | 显示全部楼层 |阅读模式
制作专门适用于小白学习的内部教程,分享给童鞋们进行学习,有需要的可以联系我,也可以加我的扣扣(二六三八一五七六四八),不图回报,请叫我雷锋。
2.jpg
一、实验目的
熟练掌握 vlan 创建,划分以及 trunk 的配置与原理。四台PCIP地址一
个网段,PC1PC3vlan2 中。PC2PC4 vlan3中,实现同vlan间的 PC
通信,同vlanPC隔离。
二、实验步骤  
PC在实验环境中用4台路由器模拟
PC1R1  
PC2R2,  
PC3R3
PC4R4
分别用自己FO/O接口与交换机相连。只要配置IP地址,关闭路由功能即可 no  ip  routing
sw1:  
w1#vlan database  /进入vlan配置数据库模式下
sw1(vlan)#vlan 2 name v2  /创建vlan2并且给他起个名字V2  
VLAN 2 added:  
Name: v2  
sw1(vlan)#vlan 3 name v3  /创建vlan3并且给他起个名字V3  
VLAN 3 added:  
Name: v3  
sw1(vlan)#exit
APPLY completed.  
Exiting....  /退出时会自动把VLAN信息保存在NVRME寄存器中
sw1#  
sw1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.  
sw1(config)#interface f0/1
sw1(config-if)#switchport mode access  /指定这个接口时二层接入端口
sw1(config-if)#switchport access vlan2  /把这个端口划分进VLAN2
sw1(config-if)#exit
sw1(config)#interface f0/2
sw1(config-if)#switchport mode access    /指定这个接口时二层接入端口
sw1(config-if)#switchport access vlan3   /把这个端口划分进VLAN3sw1(config-if)#exit
sw1(config)#interface f0/3  
sw1(config-if)#switchport mode trunk    /指定F0/3接口为trunk接口
*Mar  1 00:18:07.331: %DTP-5-TRUNKPORTON: Port Fa0/3 has become
dot1q  
trunk  
sw1(config-if)#switchport trunk encapsulation dot1q  /trunk封装dot1q  
sw1(config-if)#exit  
sw1(config)#exit
w1#show vlan-switch brief     /查看本地VLAN信息
VLAN Name Status Ports
---- -------------------------------- --------- -------------------  
1    default      active    Fa0/0,  Fa0/4, Fa0/5,  Fa0/6  
Fa0/7,  Fa0/8,  Fa0/9,  Fa0/10  
Fa0/11,  Fa0/12,  Fa0/13,  Fa0/1  
Fa0/15
2   v2              active    Fa0/1  
3   v3              active    Fa0/2  
1002 fddi-default        active  
1003 token-ring-default   active  
1004 fddinet-default     active  
1005 trnet-default       active
可以看到由三个vlan,分别是默认的vlan1vlan2vlan3FO/1接口已经
划分进vlan2中,F0/2接口已经划分进vlan3中了,其余接口都默认在vlan1
sw1#show interfaces trunk     /查看trunk状态
Port      Mode      Encapsulation Status       Native vlan
Fa0/3     on      802.1q      trunking   1  
可以看到F0/3接口状态为trunk,封装802.1q, 状态已经trunking了, 说明
trunk已经正常起来了
(由于个人原因,程序没有写完整,不过,大家可以加一下我的联系方式,我会一一发给大家)

回复

使用道具 推荐此帖

使用高级回帖 (可批量传图、插入视频等)快速回复

您需要登录后才可以回帖 登录 | 注册

本版城市盾规则   Ctrl + Enter 快速发布